酷我音乐api解析源码-Shell PHP 易语言

2017年12月30日

原创内容,转载请注明出处:http://www.myzhenai.com.cn/post/2939.html http://www.myzhenai.com/thread-18068-1-1.html
关键词:酷我音乐解析源码 酷我音乐api 酷我音乐解析shell 酷我音乐解析php 酷我音乐易语言
这个是利用酷我音乐平台的一个api接口实现的酷我音乐上的歌曲信息的获取,包含了歌曲名称,歌曲演唱者,歌曲logo,歌曲链接等。都是通过读取网页返回内容进行过滤操作的,这里只需要知道网页公开的api和歌曲的ID就可以进行。
SHELL源码

# !/bin/bash
. /etc/profile
############################################################################################################################################
#
# This is a lottery number automatic generation tool
# Autor: RucLinux
# Web: http://www.myzhenai.com.cn/ http://www.myzhenai.com/ http://www.haikou-china.com/ http://jiayu.mybabya.com/ http://www.0898-shop.com/
#  说明:转载引用请保留这段,谢谢
#
#############################################################################################################################################
pw="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"

#http://www.kuwo.cn/yinyue/24720751
###########################################################################################################
function kuwo() {
id=$(echo "${1}" | awk -F "yinyue/" '{ print $2 }')
d=$(curl -s http://player.kuwo.cn/webmusic/st/getNewMuiseByRid?rid=MUSIC_${id})
name=$(echo ${d} | awk -F "<name>" '{ print $2 }' | awk -F "</name>" '{ print $1 }')
auto=$(echo ${d} | awk -F "<singer>" '{ print $2 }' | awk -F "</singer>" '{ print $1 }')
ico=$(echo ${d} | awk -F "<artist_pic240>" '{ print $2 }' | awk -F "</artist_pic240>" '{ print $1 }')
m=$(echo ${d} | awk -F "<mp3dl>" '{ print $2 }' | awk -F "</mp3dl>" '{ print $1 }')
p=$(echo ${d} | awk -F "<mp3path>" '{ print $2 }' | awk -F "</mp3path>" '{ print $1 }')
mp=$(echo "http://${m}/resource/${p}")
one="			{\n"
two="				title : "
three="				singer :"
four="				cover  :"
fives="				src    : "
six="			},\r"
echo -e "${one}${two}'${name}',\r${three}'${auto}',\r${four}'${ico}',\r${fives}'${mp}'\r${six}" >> ${pw}/in.log
wget -p ${pw} -O "${name}.mp3" ${mp}
}
###########################################################################################################
kuwo ${1}

#pw 变量是获取当前用户所在目录
#function 是新建一个函数
#wangyi 是新建的函数
#id 这个变量是通过 $1 参数来获取当前用户输入的网页地址里的一段字符串,也就是歌曲的ID码
#d 这个变量是通过curl来读取网页信息
#name 这个变量是通过过滤返回的网页源码并获取歌曲标题这些关键词
#auto 这个变量是通过过滤返回的网页源码获取歌曲的演唱者
#ico 这个变量是通过过滤返回的网页源码获取歌曲唱片图片
#m 这个变量是歌曲链接的地址
#p 这个变量是歌曲连接的文件名
#mp 这个变量是通过合并源码里的两段信息获取歌曲的链接地址
#one two three four fives six这几个变量是定义输出的格式的关键字
#in.log 这一行是将所有变量集中输出到一个文件里,以便其他方式调用
#wget 这一行是下载歌曲文件


PHP源码

function kuwo($id)
    /**
     * 酷我音乐地址解析
     * $id 这是歌曲链接变量
     * $rid 这是歌曲链接里的歌曲ID
     * $durl 这是歌曲网页源码变量
     * $sname 这是歌曲名称变量
     * $aname 这是歌手名称变量
     * $picurl 这是专辑图片地址变量
     * $mpurl 这是音乐外链地址变量
     */
{
    preg_match("\d+", $id, $rid);
    $durl = file_get_contents("http://player.kuwo.cn/webmusic/st/getNewMuiseByRid?rid=MUSIC_" . $rid);
    $sname = getmusiczid($durl, "<name>", "</name>");
    $aname = getmusiczid($durl, "<singer>", "</singer>");
    $picurl = getmusiczid($durl, "<artist_pic240>", "</artist_pic240>");
    $mpdl = getmusiczid($durl, "<mp3dl>", "</mp3dl>");
    $aacdl = getmusiczid($durl, "<aacdl>", "</aacdl>");
    $mppath = getmusiczid($durl, "<mp3path>", "</mp3path>");
    $aacpath = getmusiczid($durl, "<aacpath>", "</aacpath>");
    $aacurl = "http://" . $aacdl . "/resource/" . $aacpath;
    $mpurl = "http://" . $mpdl . "/resource/" . $mppath;
    $muscz = array("歌曲名称" => $sname, "歌手名称" => $aname, "专辑图片" => $picurl, "歌曲地址" => $mpurl, "AAC音频" => $aacurl);
    return $muscz;
}


易语言源码

.版本 2
.支持库 iconv

.子程序 酷我, , , 酷我音乐
.参数 歌曲地址, 文本型
.局部变量 tid, 文本型
.局部变量 页面内容, 文本型
.局部变量 sname, 文本型
.局部变量 aname, 文本型
.局部变量 picurl, 文本型
.局部变量 mpurl, 文本型
.局部变量 mpdl, 文本型
.局部变量 aacdl, 文本型
.局部变量 mppath, 文本型
.局部变量 aacpath, 文本型
.局部变量 aacurl, 文本型

tid = getid (歌曲地址, “_”)
API下载 (“http://player.kuwo.cn/webmusic/st/getNewMuiseByRid?rid=MUSIC_” + tid, api_取特定目录 (17) + tid + “.html”)
页面内容 = 到文本 (编码转换 (读入文件 (api_取特定目录 (17) + tid + “.html”), #编码_UTF_8, #编码_GB2312, ))
sname = Getmusicz (页面内容, “<name>”, “</name>”)
aname = Getmusicz (页面内容, “<artist>”, “</artist>”, 真)
picurl = Getmusicz (页面内容, “<artist_pic240>”, “</artist_pic240>”)
mpdl = Getmusicz (页面内容, “<mp3dl>”, “</mp3dl>”)
aacdl = Getmusicz (页面内容, “<aacdl>”, “</aacdl>”)
mppath = Getmusicz (页面内容, “<mp3path>”, “</mp3path>”)
aacpath = Getmusicz (页面内容, “<aacpath>”, “</aacpath>”)
aacurl = “http://” + aacdl + “/resource/” + aacpath
mpurl = “http://” + mpdl + “/resource/” + mppath
tow_编辑框.加入文本 (“歌曲名称:” + sname + #换行符 + “歌手名称:” + aname + #换行符 + “专辑图片:” + picurl + #换行符 + “外链地址:” + mpurl + #换行符 + “aac格式地址:” + aacurl + #换行符 + #换行符)
删除文件 (api_取特定目录 (17) + tid + “.html”)
two_标签.标题 = #autol + mpurl + #autos
htmlplayer (mpurl)


sicnature ---------------------------------------------------------------------
Your current IP address is: 54.242.175.98
Your IP address location: 美国
Your IP address country and region: 美国 美国
Your current browser is:
Your current system is:
Original content, please indicate the source:
同福客栈论坛 | 海南仙岛海南乡情论坛 | JiaYu Blog
sicnature ---------------------------------------------------------------------
Welcome to reprint. Please indicate the source http://www.myzhenai.com.cn/post/2939.html

没有评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注