Posts Tagged ‘audacity’

linux下编译安装wxWidgets-2.8.12和audacity-2.0.3教程

星期一, 八月 12th, 2013

原创内容,转载请注明出处:http://www.myzhenai.com/thread-15778-1-1.html http://www.myzhenai.com.cn/post/1247.html
音频编辑录音器(Audacity)是一个免费的跨平台(包括Linux、Windows、Mac OS X)音频编辑器。你可以使用它来录音,播放,输入输出WAB、AIFF、Ogg Vorbis和MP3文件,并支持大部份常用的工具,如剪裁、贴上、混音、升/降音以及变音特效等功能。你可以剪切,复制和粘贴(带有无约束的取消),混合音轨,和给录音添加效果。它还有一个内置的封装编辑器,一个用户可自定义的声谱模版和实现音频分析功能的频率分析窗口。Audacity 让你轻松编辑音乐文件无负担&def提供了理想的音乐文件功能自带的声音效果包括回声,更改节拍,减少噪音,而内建的剪辑、复制、混音与特效功能,更可满足一般的编辑需求。它还支持VST和LADSPA 插件效果。
怎样编译Audacity
依赖性
wxWidgets 库是必需的。Audacity 2.0.3依赖于 wxGTK 2.8.12。 libsndfile 库也是必需的,可在Audacity SVN找到。其他库都是 可选安装。
CMake是必需的,用于编译 libsoxr (现在是Audacity默认重采样库)。
如果你使用Apt或者RPM类的系统包管理器安装库,那么每个库都得选择 “dev” (开发)版。
如果你使用yum方式来安装的话,EPel源码库里带的那个audacity1.3***版本的rpm文件版本太低了,安装可以顺利安装,但在使用的时候会提示 此版本的Audacity在编译时没有附带针对MP3文件的支持 所以我们就别外安装最新版本的,在编译的过程中我们会遇到一些问题,首先最大的问题就是wxWidgets的编译,这个问题我折腾了很久,因为我以为wxWidgets编译成功了,但是在接下来编译audacity的时候却提示没有找到wxWidgets.我第一次编译wxWidgets的时候是编译它的最新的wxWidgets2.9.5,但好像不行. 另外一个问题是cmake的版本太低,系统自带的cmake才2.6,而audacity2.0.3却需要cmake2.8.

#yum install libsndfile*
#yum install sox
#yum remove cmake
#wget http://www.cmake.org/files/v2.8/cmake-2.8.11.2.tar.gz
#tar -xzvf cmake-2.8.11.2.tar.gz
#cd cmake-2.8.11.2
#./configure
#make
#make install
#wget http://nchc.dl.sourceforge.net/project/wxwindows/2.8.12/wxWidgets-2.8.12.tar.bz2
#tar -xjvf wxWidgets-2.8.12.tar.bz2
#cd wxWidgets-2.8.12
#./configure --with-gtk --enable-unicode --disable-shared
#make
#make install
#ldconfig
#wget http://audacity.googlecode.com/files/audacity-minsrc-2.0.3.tar.xz
#xz -d audacity-minsrc-2.0.3.tar.xz
#tar -xvf audacity-minsrc-2.0.3.tar
#cd audacity-minsrc-2.0.3
#./configure
#make
#make install

OR

#cvs -d:pserver:anonymous@audacity.cvs.sourceforge.net:/cvsroot/audacity checkout audacity
#cd audacity
#./configure
#make
#make install

会遇到的问题:

configure: error: Unable to locate a suitable configuration of wxWidgets v2.8.x or higher.

=== configuring in lib-src/libsoxr (/home/RucLinux/audacity-src-2.0.3/lib-src/libsoxr)
configure: running /bin/sh ./configure –disable-option-checking ‘–prefix=/usr/local/’ ‘–disable-unicode’ ‘–without-libvorbis’ ‘–with-wx-config=/usr/local/bin/wx-config’ ‘–disable-programs’ ‘–disable-programs’ ‘–with-pa-include=../portaudio-v19/include’ –cache-file=/dev/null –srcdir=.
CMake Error at CMakeLists.txt:4 (cmake_minimum_required):
CMake 2.8 or higher is required. You are running version 2.6.4

— Configuring incomplete, errors occurred!
configure: error: ./configure failed for lib-src/libsoxr

Link:
wxwidgets:http://www.wxwidgets.org/
cmake:http://www.cmake.org/
audacity:http://audacity.sourceforge.net/

linux 编译 安装 wxWidgets-2.8.12 audacity-2.0.3 教程

linux下编译安装wxWidgets-2.8.12和audacity-2.0.3教程


linux 编译 安装 wxWidgets-2.8.12 audacity-2.0.3 教程

linux下编译安装wxWidgets-2.8.12和audacity-2.0.3教程


linux 编译 安装 wxWidgets-2.8.12 audacity-2.0.3 教程

linux下编译安装wxWidgets-2.8.12和audacity-2.0.3教程


linux 编译 安装 wxWidgets-2.8.12 audacity-2.0.3 教程

linux下编译安装wxWidgets-2.8.12和audacity-2.0.3教程