Gnome3如何设置Gnome2那样的界面
Linux / 2017年02月2日

原创内容,转载请注明出处: http://www.myzhenai.com.cn/post/2366.html http://www.myzhenai.com/thread-17962-1-1.html
关键词: Gnome fedora ubuntu debian centos7
众所周知, 新版的 centos7, fedora, ubuntu, debian等都默认安装Gnome3了, 就是界面左边一竖排的图标, 然后桌面上全是空白的, 有些人喜欢这么整洁的桌面, 但有些人还是认为这样太麻烦, 因为有些程序你找不到,得通过终端来调用. 尽管你可以通过/usr/share/applications/ 这路径下找到, 但总是不方便. 我喜欢的是Centos6默认使用的Gnome2的样式,有应用程序分类,系统功能分类. 那么,我们怎么找回这些样式呢? 也就是说,我们怎样设置Gnome3可以像Gnome2那样方便? 其实也很简单.我们只需要安装 gnome-tweak-tool就可以了.

记一次shadowsocks服务端和Linux客户端配置教程
Linux / 2017年01月25日

原创内容,转载请注明出处: http://www.myzhenai.com.cn/post/2353.html http://www.myzhenai.com/thread-17961-1-1.html
关键词: CentOS安装shadowsocks教程 shadowsocks服务端安装教程 shadowsocks客户端配置教程 Linux下如何使用shadowsocks客户端
我的服务端系统是 CentOS6 本地系统是 CentOS6.8+Gnome+firefox
安装的shadowsocks版本是: shadowsocks-libev 一键包出处: https://teddysun.com/357.html
我们首先先安装服务端, 安装前请确定您的服务器系统是干净的服务器系统, 我就试过安装后不能启动,也不能正常连接,可能问题出现在iptables端口转发上,但因为系统没有重装过,太多东西,重装系统后再重新安装问题就解决了.

Linux默认声音设备无法打开的解决方法
Linux / 2016年10月22日

原创内容,转载请注明出处: http://www.myzhenai.com.cn/post/2326.html http://www.myzhenai.com/thread-17940-1-1.html
关键词: 默认声音设备无法打开 VMware无法自动检测声卡 设置默认声卡 Linux设置默认声卡
我有一台VMware虚拟机里的CentOS系统最近运行的时候总是会弹出提示 默认声音设备无法打开 总是要手动去连接声卡, VMware无法自动检测声卡了. 刚开始的时候我以为是CentOS的声卡驱动的问题, 因为我安装的是Alsa声卡,但是检测声卡驱动的时候是显示声卡驱动安装了的. 后来又以为是Vmware tools的问题, 于是重新安装了一遍VMware tools. 却发现还是没有解决问题, 于是不得不转换思路, 会不会是虚拟的声卡驱动有多个声卡呢? 所以才导致无法确定使用哪一个声卡是默认声卡而无法识别. 后面一步一步排查,还真是. 最后就是设置了默认声卡解决了问题.步骤如下

Linux(CentOS)下的Shockwave Flash shell一键更新脚本
Linux / 2016年09月26日

原创内容,转载请注明出处: http://www.myzhenai.com.cn/post/2318.html http://www.myzhenai.com/thread-17933-1-1.html
关键字: Shockwave Flash一键更新脚本 Flash一键更新脚本
这个脚本其实是我自己用的, 我的系统里安装了FlashPlayer软件和火狐(firefox)浏览器里安装了Shockwave Flash插件,因为要一个一个来更新显得太麻烦,所以我自己写了这么一个小脚本来快速更新. 原理很简单, 从官方网站上下载FlashPlayer的最新版本到本地覆盖旧版本程序,然后通过flashplayer -v得到最新的版本号,再通过指定的官方下载链接将Shockwave Flash插件下载到本地并安装,在安装之前自动卸载旧版本的Shockwave Flash.

Linux(centos)下安装PhpStorm2016.2教程
Linux / 2016年08月19日

原创内容,转载请注昨出处: http://www.myzhenai.com.cn/post/2260.html http://www.myzhenai.com/thread-17909-1-1.html
关键词: phpstorm2016.2激活 phpstorm2016.2汉化 phpstorm2016.2中文 phpstorm2016.2安装
PhpStorm是一个轻量级且便捷的PHP IDE,其旨在提供用户效率,可深刻理解用户的编码,提供智能代码补全,快速导航以及即时错误检查.
PhpStorm官网:https://www.jetbrains.com/
PhpStorm2016.2:https://download.jetbrains.8686c.com/webide/PhpStorm-2016.2.tar.gz (Linux)
PhpStorm2016.2:https://download.jetbrains.8686c.com/webide/PhpStorm-2016.2.exe (windows)
需要的文件: 链接: https://pan.baidu.com/s/1bFaboU 密码: 6qpe
安装之前需要先安装java18以下版本. java安装教程 http://www.myzhenai.com.cn/post/1284.html 将旧版本的java安装目录删除, 将旧版本的java环境变量删除. 重新安装java
java下载页面: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
现在我们来安装PhpStorm2016.2

LAPMPP一键安装脚本
Linux / 2015年05月17日

原创内容,转载请注明出处:http://www.myzhenai.com.cn/post/2033.html http://www.myzhenai.com/thread-17477-1-1.html
关键词:Linux Apache PHP Mysql PHPmyAdmin Pure-ftpd 一键安装脚本
这个脚本是基于CentOS下的,Ubuntu和Debin因为和CentOS命令和代码是不一样的,所以这个不适用于Ubuntu和Debin.
脚本会自动识别系统版本并自动安装相对应的Epel源,安装过程中需要您输入mysql root用户密码,输入您所有网站根目录的路径,不要在最尾处加/符号(比如您有多个网站,全部存放在/var/www/ 您可以输入/var/www)您还要输入您绑定的域名,同时您还要留意输入pure-ftpd的密码,用户名是您提供的域名. 所有的配置信息保存在当前脚本执行路径下的lapmpp.log文件里.
如果有什么不明白的,可以参考以下几个文章:
Linux下利用yum安装Apache,php,Mysql,phpmysqladmin,pure-ftpd教程:http://www.myzhenai.com.cn/post/1992.html http://www.myzhenai.com/thread-17408-1-1.html
Pure-ftpd安装教程:http://www.myzhenai.com.cn/post/1812.html
脚本安装方法:

CenTos OpenVpn 一键安装包
Linux / 2015年04月19日

原创内容,转载请注明出处:http://www.myzhenai.com.cn/post/2015.html http://www.myzhenai.com/thread-17453-1-1.html
关键字:centos openvpn 一键安装包 openvpn install script
pptp一键安装包网上有很多,但是openvpn的一键安装包却很少,这个是我自己写的一个一键安装脚本,利用yum进行安装的,所以安装的版本还算不低.默认会自动识别i386或是x86_64。同时支持centos5x和centos6x.不过好像centos7x还不能够兼容openvpn,起码我在源库里并没有看到有openvpn这个安装包.
虽然说是一键安装的脚本,但是在生成key和dh文件的时候还是需要一路回车并留意输入”y”回车. 因为在这几步这里我折腾了很久也不能实现自动交互,所以也只能是麻烦用户们在这里手动一下.安装完成后需要reboot重启服务器,如果出现无法连接的故障,请检查你服务端时间和本地时间.

CenTos下双击rpm安装包不能安装的解决方法
Linux / 2015年04月15日

动作无法完成
请求失败,更多细节可在细节报告中查询
The name org.freedesktop.PackageKit was not provided by any .service files
双击rpm安装包没有弹出安装窗口,而是弹出错误窗口,不能双击安装. 发生这样的问题是因为我们系统的PackageKit系统更新应用小程序没有启动,参照下图引导启动,然后重新启动系统就解决了.

PPTPVPN服务端一键安装脚本
Linux / 2015年04月3日

原创内容,转载请注明出处:http://www.myzhenai.com.cn/post/2007.html http://www.myzhenai.com/thread-17436-1-1.html
网络上有很多VPN一键安装脚本,好多功能也比这个脚本强大和简单,但这个是我练习Linux Shell编程自己写出来的脚本代码,说分享也好,记录也罢,发出来与大家共同学习探讨. 欢迎大家指教.谢谢.
目前脚本只适用于CenTos6,因为在识别系统版本上我还搞不懂,我的本意是自动识别系统版本,然后下载安装相应版本的epel源,但还有待学习.
其实安装PPTP真的是很简单,可以参考http://www.myzhenai.com.cn/post/871.html

如何使用yum来下载RPM包
Linux / 2015年03月24日

问题:我想从Red Hat 的标准仓库中下载一个RPM包,我能使用yum命令来下载一个RPM包但是不进行安装吗?
yum是基于Red Hat的系统(如CentOS、Fedora、RHEl)上的默认包管理器。使用yum,你可以安装或者更新一个RPM包,并且他会自动解决包依赖关系。但是如果你只想将一个RPM包下载到你的系统上该怎么办呢? 例如,你可能想要获取一些RPM包在以后使用,或者将他们安装在另外的机器上。
这里说明了如何从yum仓库上下载一个RPM包。