用户信息泄密门的一点个人思考-算法变形

因为我只懂使用易语言,所以只用易语言进行演示….
在CSDN和天涯等数据被泄露的事件中,无一不暴露出开发商与开发平台对用户信息的保护薄弱,很多平台居然使用的是明码保存用户信息和密码.
目前使用最广泛的加密方式是MD5加密,对于网上说的MD5对碰破解,因为对这方面没有怎么接触过,不过我大致以为,所谓的MD5碰撞破解可能就是把常用的一些用户名和密码事先用MD5加密后存入数据库,这样可以得知这些用户名和密码MD5加密后的内容,例如:
admin|123456789MD5加密过后的内容就是07abd66a8edf1bdd4b0ec3aefd79d26a在得到用户名和密码后,可以用MD5加密这些数据再和数据库里的碰撞对比,如果加密后的MD5哈希值是07abd66a8edf1bdd4b0ec3aefd79d26a那我们就知道用户名和密码是admin|123456789.
简单的MD5加密可能会被破解,但是如果开发平台或开发者在加密注册用户信息的时候添加指定的字符窜或内容再进行加密,或者多重MD5加密后再把数据保存进数据库,以后用户登录的时候,再用这个数据去对碰数据库里的数据,相信安全性能会高很多,被破解的概率也会小很多.

.版本 2
.支持库 dp1

.程序集 窗口程序集1

.子程序 _按钮1_被单击

.如果 (编辑框1.内容 ≠ “” 且 编辑框2.内容 ≠ “”)
    编辑框3.内容 = 取数据摘要 (到字节集 (编辑框1.内容 + “|” + 编辑框2.内容))
    ' 置剪辑板文本 (编辑框3.内容)
    编辑框4.内容 = 取数据摘要 (到字节集 (编辑框1.内容 + “|” + 编辑框3.内容))
.否则
    信息框 (“您没有输入用户名或密码,请重新输入!”, #信息图标, 标题)
.如果结束



sicnature ---------------------------------------------------------------------
Your current IP address is: 54.159.239.251
Your IP address location: 美国
Your IP address country and region: 美国 美国
Your current browser is:
Your current system is:
Original content, please indicate the source:
同福客栈论坛 | 海南仙岛海南乡情论坛 | JiaYu Blog
sicnature ---------------------------------------------------------------------
Welcome to reprint. Please indicate the source http://www.myzhenai.com.cn/post/629.html

Tags: , ,

Leave a Reply