Linux下的电影播放机Totem

Totem:https://projects.gnome.org/totem/
Totem是什么?

Totem是官方的GNOME桌面环境基于GStreamer的电影播放器​​。它具有播放列表,全屏模式,寻求和音量控制,以及键盘导航。
它配备了更多功能,例如:

视频缩略图的文件管理器
鹦鹉螺“属性”选项卡
Mozilla的火狐插件在你的浏览器观看电影
命令行的视频属性帮手(索引)
特点

播放任何GStreamer的支持文件
支持LIRC
Shoutcast的,M3U,ASX,SMIL和ra播放列表的支持(也可用从运LGPL库)
播放VCD,DVD(菜单),圆盘式自动检测
TV-Out功能配置可选的分辨率切换
4.0,4.1,5.0,5.1,立体声和AC3输出音频的输出
Xinerama的双头和视支持全屏模式(移动鼠标,你会得到很好的控制)
遥控器的操作模式来控制正在运行的Totem
寻求和音量控制
长宽比的变化,基于视频的原始大小缩放
全键盘控制
播放列表,重复和随机模式,节能功能和拖放重新排序
GNOME和Nautilus集成(Totem注册的文件类型,添加了一个菜单项,使用代理服务器的配置,节约会议,并注册,MMS,PNM uvox和RTSP计划的,删除播放列表中的项目,从弹出的光盘)
属性窗口(关于当前电影的信息)
拖放和鼠标滚轮的行动
屏幕截图功能
亮度,对比度,色调和饱和控制
可视化插件播放音频文件时,
Telestrator模式下使用超级无敌掌门狗
视频缩略图
鹦鹉螺属性页
在远程显示器上的作品
自动外挂字幕加载,或手动(仅适用于命令行,使用这样的:Totem文件:///文件。avi#副标题:file.srt)
DVD,VCD和OGG/ OGM字幕和语言支持
更准确的寻求对话
身份验证对话框时位置需要

GStreamer的

使用GStreamer的后端时,你可以安装多个插件包。您可以安装他们以同样的方式,你会安装Totem。可以在这里找到一些有关的GStreamer插件包。

GST-插件基
基本和必要的GStreamer插件
GST-插件好
大多数开放格式的插件
GST-插件丑
优质的插件可能会造成分配问题,需要DVD播放
GST-插件坏
一组插件,需要更多的工作,需要DVD播放
GST-ffmpeg的
基于FFmpeg的插件,包含了所有的基本流行的编解码器,如DivX和WMV解码器
安装方法:

#yum install totem*
[root@localhost RucLinux]# yum install totem*
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: mirrors.hustunique.com
* extras: mirrors.hustunique.com
* updates: mirrors.stuhome.net
http://mirrors.hustunique.com/centos/6.4/os/i386/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 502 Bad Gateway"
Trying other mirror.
base                                                     | 3.7 kB     00:00     
http://mirrors.hustunique.com/centos/6.4/extras/i386/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 502 Bad Gateway"
Trying other mirror.
extras                                                   | 3.5 kB     00:00     
updates                                                  | 3.4 kB     00:00     
updates/primary_db                                       | 3.5 MB     00:07     
Setting up Install Process
Package totem-nautilus-2.28.6-2.el6.i686 already installed and latest version
Package totem-2.28.6-2.el6.i686 already installed and latest version
Package totem-upnp-2.28.6-2.el6.i686 already installed and latest version
Package totem-mozplugin-2.28.6-2.el6.i686 already installed and latest version
Package totem-pl-parser-2.28.3-1.el6.i686 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package totem-devel.i686 0:2.28.6-2.el6 will be installed
---> Package totem-jamendo.i686 0:2.28.6-2.el6 will be installed
---> Package totem-pl-parser-devel.i686 0:2.28.3-1.el6 will be installed
---> Package totem-youtube.i686 0:2.28.6-2.el6 will be installed
--> Processing Dependency: libgdata.so.6 for package: totem-youtube-2.28.6-2.el6.i686
--> Running transaction check
---> Package libgdata.i686 0:0.5.0-2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package                      Arch        Version             Repository   Size
================================================================================
Installing:
totem-devel                  i686        2.28.6-2.el6        base         67 k
totem-jamendo                i686        2.28.6-2.el6        base         41 k
totem-pl-parser-devel        i686        2.28.3-1.el6        base         32 k
totem-youtube                i686        2.28.6-2.el6        base         36 k
Installing for dependencies:
libgdata                     i686        0.5.0-2.el6         base        171 k

Transaction Summary
================================================================================
Install       5 Package(s)

Total download size: 347 k
Installed size: 1.4 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): libgdata-0.5.0-2.el6.i686.rpm                     | 171 kB     00:00     
(2/5): totem-devel-2.28.6-2.el6.i686.rpm                 |  67 kB     00:00     
(3/5): totem-jamendo-2.28.6-2.el6.i686.rpm               |  41 kB     00:00     
(4/5): totem-pl-parser-devel-2.28.3-1.el6.i686.rpm       |  32 kB     00:00     
(5/5): totem-youtube-2.28.6-2.el6.i686.rpm               |  36 kB     00:00     
--------------------------------------------------------------------------------
Total                                           285 kB/s | 347 kB     00:01     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : totem-pl-parser-devel-2.28.3-1.el6.i686                      1/5
  Installing : totem-jamendo-2.28.6-2.el6.i686                              2/5
  Installing : totem-devel-2.28.6-2.el6.i686                                3/5
  Installing : libgdata-0.5.0-2.el6.i686                                    4/5
  Installing : totem-youtube-2.28.6-2.el6.i686                              5/5
  Verifying  : totem-devel-2.28.6-2.el6.i686                                1/5
  Verifying  : libgdata-0.5.0-2.el6.i686                                    2/5
  Verifying  : totem-jamendo-2.28.6-2.el6.i686                              3/5
  Verifying  : totem-pl-parser-devel-2.28.3-1.el6.i686                      4/5
  Verifying  : totem-youtube-2.28.6-2.el6.i686                              5/5

Installed:
  totem-devel.i686 0:2.28.6-2.el6            totem-jamendo.i686 0:2.28.6-2.el6
  totem-pl-parser-devel.i686 0:2.28.3-1.el6  totem-youtube.i686 0:2.28.6-2.el6

Dependency Installed:
  libgdata.i686 0:0.5.0-2.el6                                                   

Complete!
[root@localhost RucLinux]# yum install totem*
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: mirrors.hustunique.com
* extras: mirrors.hustunique.com
* updates: mirrors.stuhome.net
Setting up Install Process
Package totem-nautilus-2.28.6-2.el6.i686 already installed and latest version
Package totem-youtube-2.28.6-2.el6.i686 already installed and latest version
Package totem-jamendo-2.28.6-2.el6.i686 already installed and latest version
Package totem-devel-2.28.6-2.el6.i686 already installed and latest version
Package totem-2.28.6-2.el6.i686 already installed and latest version
Package totem-upnp-2.28.6-2.el6.i686 already installed and latest version
Package totem-mozplugin-2.28.6-2.el6.i686 already installed and latest version
Package totem-pl-parser-2.28.3-1.el6.i686 already installed and latest version
Package totem-pl-parser-devel-2.28.3-1.el6.i686 already installed and latest version
Nothing to do
[root@localhost RucLinux]#

安装GStreamer和FFmpeg插件的方法.
GStreamer:http://www.myzhenai.com/thread-15776-1-1.html http://www.myzhenai.com.cn/post/1238.html
FFmpeg:http://www.myzhenai.com/thread-15774-1-1.html http://www.myzhenai.com.cn/post/1236.html
linux下Totem电影播放器有声音没图像的解决方法:http://www.myzhenai.com/thread-15634-1-1.html
Centos6.0安装Quicktime:http://www.myzhenai.com/thread-14390-1-2.html
centos6播放mp3文件:http://www.myzhenai.com/thread-14328-1-3.html
Totem播放rmvb和rm格式文件:http://www.myzhenai.com/thread-15635-1-1.html
把这个帖子里的cook.dll drvc.dll Pncrt.dll sipr.dll这四个文件cp到~/.gnome2/totem-addons/目录下.然后从Mplayer官方网站http://www.mplayerhq.hu/MPlayer/releases/codecs/下载一些常用的解码插件解压后也cp到~/.gnome2/totem-addons/目录下,这样Totem就可以支持常见格式的音频和视频播放了.

Linux 电影播放机 Totem

Linux下的电影播放机Totem


Linux 电影 播放机 Totem

Linux下的电影播放机Totem


Linux 电影播放机 Totem

Linux下的电影播放机Totem


sicnature ---------------------------------------------------------------------
Your current IP address is: 54.197.75.176
Your IP address location: 美国
Your IP address country and region: 美国 美国
Your current browser is:
Your current system is:
Original content, please indicate the source:
同福客栈论坛 | 海南仙岛海南乡情论坛 | JiaYu Blog
sicnature ---------------------------------------------------------------------
Welcome to reprint. Please indicate the source http://www.myzhenai.com.cn/post/1240.html

Tags: , , , ,

Leave a Reply